Computer >> บทช่วยสอนคอมพิวเตอร์ >  >> ระบบเครือข่าย >> ระบบเครือข่าย

รายการ TCP/UDP Ports (Well-Known Ports 0-1023) พร้อมคำอธิบาย

TCP (Transmission Control Protocol) และ UDP (User Datagram Protocol) ใช้ Port Number สำหรับช่องทางการสื่อสาร Port 0-1023 = Well-known System Ports สำรองไว้ใช้งานพิเศษ

Port 0: ไม่ใช้สื่อสาร TCP/UDP แต่ใช้ใน Network Programming

ตาราง Well-Known Ports (บางส่วนสำคัญ)

Port Protocol Service / คำอธิบาย RFC/หมายเหตุ
1TCPTCPMUX - TCP Port Service MultiplexerRFC 1078
5TCP/UDPRemote Job EntryRFC 407
7TCP/UDPEcho (Debug: ส่งข้อมูลกลับต้นทาง)RFC 862
9TCP/UDPDiscard (Debug: ทิ้งข้อมูล)RFC 863
11TCPActive Users (Unix systat)RFC 866
13TCP/UDPDaytimeRFC 867
17TCP/UDPQuote of the Day (qotd)RFC 865
18TCP/UDPMessage Send / Remote Write ProtocolRFC 1312, 1756
19TCP/UDPCharacter Generator ProtocolRFC 864
20TCPFTP Data
21TCPFTP Control
22TCPSSH Remote Login
23TCPTelnet
25TCPSMTP (Simple Mail Transfer Protocol)RFC 821
37TCP/UDPTime ProtocolRFC 868
42UDPHost Name Server (Microsoft WINS)
43TCPWHOIS / NICNAMERFC 954
53TCP/UDPDNS (Domain Name Server)
67TCP/UDPBOOTP Server / DHCP Server (Unofficial)RFC 951
68TCP/UDPBOOTP Client / DHCP Client (Unofficial)RFC 951
69TCP/UDPTFTP (Trivial File Transfer Protocol)RFC 906, 1350
70TCP/UDPGopherRFC 1436
79TCP/UDPFinger User Information ProtocolRFC 1288
80TCPHTTP (Hypertext Transfer Protocol)RFC 2616
88TCP/UDPKerberos Network AuthenticationRFC 1510
110TCPPOP3
119TCPNNTP (Network News Transfer Protocol)
123UDPNTP (Network Time Protocol)
137-139TCP/UDPNetBIOS (Name/Datagram/Session)
143TCPIMAP4
161UDPSNMP
162UDPSNMP Trap
179TCPBGP (Border Gateway Protocol)
194TCPIRC (Internet Relay Chat)
389TCP/UDPLDAP
443TCPHTTPS (HTTP over TLS/SSL)
465TCPSMTPS (SMTP over SSL)
514TCP/UDPSyslog
515TCPLPR (Line Printer Daemon)
587TCPSMTP Submission
636TCPLDAPS (LDAP over SSL)
993TCPIMAPS (IMAP over SSL)
995TCPPOP3S (POP3 over SSL)

หมายเหตุ: ตารางข้างต้นแสดงเฉพาะ Port ยอดนิยมและสำคัญ รายการเต็ม 0-1023 มีมากกว่า 100 รายการ