ในบทความนี้ เราจะพูดถึงว่า SNMP คืออะไร และวิธีติดตั้ง เปิดใช้งาน และกำหนดค่า SNMP service ใน Windows 10 SNMP ย่อมาจาก Simple Network Management Protocol เป็นโปรโตคอลอินเทอร์เน็ตมาตรฐานที่ใช้ควบคุมและจัดการการสื่อสารระหว่างอุปกรณ์เครือข่ายหลายตัวที่เชื่อมต่อผ่าน IP มันช่วยให้องค์กรสามารถติดตามอุปกรณ์เครือข่ายที่แตกต่างกันได้ รวมถึง routers, workstations, modems, switches, servers, printers ฯลฯ SNMP ถูกกำหนดค่าไว้แล้วบนอุปกรณ์เครือข่ายส่วนใหญ่ และเมื่อโปรโตคอลถูกเปิดใช้งาน สถิติประสิทธิภาพของอุปกรณ์จะถูกเก็บไว้

มาเจาะลึกส่วนประกอบหลักของ SNMP
ส่วนประกอบหลักของ SNMP
นี่คือส่วนประกอบสำคัญของสภาพแวดล้อมที่จัดการโดย SNMP:
SNMP manager: เป็นระบบศูนย์กลางที่จัดการและติดตามเครือข่าย SNMP ยังเรียกว่า Network Management Station (NMS) และรันบนโฮสต์บนเครือข่าย SNMP manager โดยพื้นฐานจะส่ง query ไปยัง SNMP agent รับคำขอ
SNMP agent: เป็นกระบวนการซอฟต์แวร์ที่ให้สถานะและสถิติของ network node เมื่อได้รับ SNMP query เป็นส่วนประกอบสำคัญในการจัดการ SNMP ที่เก็บรวบรวม จัดเก็บ และส่งข้อมูลการติดตามไปยัง SNMP managers
Managed Devices: อุปกรณ์เหล่านี้รวมถึงอุปกรณ์เครือข่ายที่เปิดใช้งาน SNMP ทั้งหมดที่คุณต้องการติดตาม เช่น printers, routers, wireless devices ฯลฯ
SNMP MIB: SNMP ใช้การออกแบบที่ขยายได้ด้วยลำดับชั้นที่กำหนดเป็น Management Information Base (MIB) ที่ใช้ object identifiers (OIDs) สำหรับการจัดการ network entity มันถูกกำหนดหลักเป็นรูปแบบการแลกเปลี่ยนข้อมูลในโมเดลการจัดการ SNMP แต่ละ network servers มี MIB files ที่ถูกส่ง query เพื่อรวบรวมข้อมูลการติดตาม
SNMP OID: OID หรือ Object Identifiers จัดระเบียบอยู่ในฐานข้อมูล MIB ในโครงสร้างต้นไม้ ซึ่งมีคุณสมบัติที่จัดการได้ของผลิตภัณฑ์ทั้งหมด
เวอร์ชัน SNMP
มี SNMP พื้นฐาน 3 เวอร์ชัน คือ:
- SNMPv1: เวอร์ชันแรกของโปรโตคอล SNMP ที่กำหนดใน RFC 1155 และ 1157
- SNMPv2c: เวอร์ชันที่ปรับปรุงแล้ว และกำหนดใน RFC 1901, RFC 1905, และ RFC 1906
- SNMPv3: เวอร์ชันล่าสุดของ SNMP จนถึงตอนนี้ ที่ส่งเสริมการกำหนดค่า SNMP entities แบบ remote มันเป็นเวอร์ชันที่ปลอดภัยที่สุดจนถึงตอนนี้ และกำหนดใน RFC 1905, RFC 1906, RFC 2571, RFC 2572, RFC 2574, และ RFC 2575
คำสั่ง SNMP พื้นฐาน
นี่คือคำสั่ง SNMP หลักที่ใช้ในโมเดลการจัดการเครือข่าย:
- GET: SNMP manager ส่งคำขอ GET ไปยัง managed devices เพื่อรับค่าหนึ่งหรือหลายค่า
- GET NEXT: คำสั่งนี้ใช้ดึงค่า OID ถัดไปใน MIB tree
- GET BULK: คำสั่งนี้ใช้ query และดึงข้อมูลจำนวนมากจากตาราง MIB ขนาดใหญ่
- SET: เพื่อแก้ไขหรือเพิ่มค่าของ managed devices คำสั่งนี้ถูกใช้โดย SNMP managers
- TRAPS: คำสั่งแบบนี้เริ่มต้นโดย SNMP agent เพื่อส่งสัญญาณไปยัง SNMP manager เมื่อมีเหตุการณ์เกิดขึ้น
- INFORM: คำสั่งอื่นที่เริ่มต้นโดย SNMP agent รวมถึงการยืนยันเมื่อ SNMP manager ได้รับข้อความ
- RESPONSE: คำสั่งนี้ส่งคืนค่าหรือสัญญาณของการกระทำที่ SNMP manager สั่ง
องค์กร IT สามารถใช้ซอฟต์แวร์ SNMP monitoring เฉพาะทาง เช่น PRTG Network Monitor หรือ Spiceworks Network Monitor เพื่อจัดการและติดตามอุปกรณ์เครือข่ายและสถิติประสิทธิภาพ นี่คือการใช้งานทั่วไปของเครื่องมือ SNMP monitoring:
- ใช้เพื่อ discovery, manage, organize, และ monitor network devices ในองค์กร
- เปิดใช้งานการมองเห็นประสิทธิภาพของ network devices อย่างสมบูรณ์
- วิเคราะห์สถิติและข้อมูลต่างๆ ของอุปกรณ์เครือข่ายที่เชื่อมต่อ เช่น connectivity, availability, performance, bandwidth, traffic, network usage graphs และอื่นๆ
- อนุญาตให้ตั้งค่า threshold limits สำหรับการใช้งานเครือข่าย
- ปล่อยให้ trigger alerts ในกรณีของข้อยกเว้นหรือความไม่สอดคล้อง
ตอนนี้ มาดูวิธีที่คุณสามารถติดตั้งและเปิดใช้งาน SNMP service และจากนั้นกำหนดค่ามันบน Windows 10
วิธีติดตั้งและเปิดใช้งาน SNMP service ใน Windows 11/10
SNMP เคยเป็นฟีเจอร์ที่ติดตั้งมาก่อนใน Windows เวอร์ชันก่อนหน้า อย่างไรก็ตาม SNMP ตอนนี้ถูกพิจารณาว่า deprecated และทำเป็น Optional Feature/ Feature on Demand (FOD) ใน Windows 10 version 1809 และใหม่กว่า Windows ตอนนี้แนะนำให้ใช้ Common Information Model (CIM) ที่ได้รับการรองรับโดย Windows Remote Management
ใน Windows 10 builds ล่าสุด SNMP สามารถติดตั้งและเปิดใช้งานได้ผ่านแอป Settings โดยใช้ตัวเลือก optional features

นี่คือขั้นตอนในการเปิดใช้งานและกำหนดค่า SNMP ใน Windows 10 โดยใช้ Settings:
- กด Windows + I hotkey เพื่อเปิดแอป Settings
- ไปที่หมวดหมู่ Apps และไปที่แท็บ Apps & features
- แตะที่ปุ่ม Optional features
- บนหน้าใหม่ ให้คลิกที่ปุ่ม Add a feature
- เลื่อนลงถึง Simple Network Management Protocol (SNMP) และเลือกมัน
- กดปุ่ม Install เพื่อเปิดใช้งาน SNMP บนคอมพิวเตอร์ของคุณ
คุณยังสามารถใช้ Control Panel เพื่อเปิดใช้งาน SNMP บนคอมพิวเตอร์ของคุณได้ หากคุณใช้ Windows 10 build เก่าหรือแม้แต่ Windows 8

เพียงใช้ขั้นตอนต่อไปนี้สำหรับนั้น:
- เปิด Run โดยใช้ Windows + R และป้อน "control panel" แล้วกด Enter
- ไปที่ Programs and Features แล้วคลิกที่ Turn Windows features on or off option
- ในรายการ Windows Features ให้เลือก Simple Network Management Protocol (SNMP) และกด OK เพื่อติดตั้งมัน
วิธีกำหนดค่า SNMP service ใน Windows 10
หลังจากติดตั้งแล้ว คุณต้องกำหนดค่า SNMP service ใน Windows 10 มี SNMP services หลักสองอย่างที่รวมถึง:
- SNMP Service – บริการหลักสำหรับติดตามและส่งข้อมูล
- SNMP Trap – เพื่อรับ trap messages จาก SNMP agents และส่งต่อไปยัง SNMP management software

บริการเหล่านี้ต้องเริ่มต้นอัตโนมัติหลังจากติดตั้ง SNMP คุณสามารถตรวจสอบและกำหนดค่าได้จาก Services Manager เพียงเปิดแอป Services โดยกด Windows + R hotkey เพื่อเรียก Run dialog และป้อน "services.msc" ในมัน ในหน้าต่าง Servies ให้เลื่อนลงถึง SNMP service ในรายการและดูว่ามันกำลังทำงานหรือไม่ หากไม่ได้ทำงาน ให้คลิกปุ่ม Start เพื่อเริ่ม SNMP service นอกจากนี้ ตั้งค่า startup type เป็น Automatic
คุณสามารถตั้งค่าคุณสมบัติ SNMP service ต่างๆ เพิ่มเติมได้ รวมถึง Agent, Security ฯลฯ เพียงคลิกขวาที่ SNMP service และเลือกตัวเลือก Properties

ในหน้าต่าง Properties ให้ไปที่แท็บ Agent ซึ่งคุณสามารถกำหนดค่าข้อมูล SNMP agent ได้ คุณสามารถเพิ่มรายละเอียด contact และ location เพื่อระบุชื่อผู้ติดต่อของผู้ใช้หรือผู้ดูแลระบบและตำแหน่งที่ตั้งทางกายภาพของคอมพิวเตอร์ เพิ่มเติม คุณสามารถเปิดใช้งานหรือปิดใช้งานบริการห้าบริการจากรายการที่คุณรับข้อมูลการติดตามและส่งไปยังอุปกรณ์การติดตาม บริการเหล่านี้รวมถึง Physical, Applications, Datalink and subnetwork, Internet และ End-to-end

เพื่อกำหนดค่าการตั้งค่าความปลอดภัยบางอย่างสำหรับ SNMP servers ที่แตกต่างกัน คุณสามารถไปที่แท็บ Security ในหน้าต่าง Properties ในรายการ Accepted community names คุณสามารถดูและเพิ่ม SNMP hosts ที่ได้รับการยืนยันตัวตนสำหรับการส่ง SNMP requests เพื่อเพิ่ม community ให้คลิกที่ปุ่ม Add และพิมพ์ชื่อ community คุณสามารถให้สิทธิ์ None, Notify, READ ONLY, READ WRITE หรือ READ CREATE access ให้กับ community เฉพาะ
คุณสามารถเพิ่มรายการ SNMP monitoring servers พร้อมที่อยู่ IP ในรายการ Accept SNMP packets from these hosts นี่คือการระบุ servers ที่ SNMP packets ถูกยอมรับ ในกรณีที่คุณเปิดใช้งานตัวเลือก Accept SNMP packets from any host ไม่มีการบังคับข้อจำกัด IP บน SNMP agent สำหรับการรับ SNMP packets ตัวเลือกนี้ไม่ปลอดภัย และจึงไม่แนะนำบนคอมพิวเตอร์สาธารณะ
IT admins สามารถกำหนดค่าการตั้งค่าอื่นๆ ที่เกี่ยวข้องกับ SNMP เพิ่มเติม และติดตามอุปกรณ์เครือข่ายที่เชื่อมต่อทั้งหมดโดยใช้ SNMP management software และเครื่องมือ
หวังว่าบทความนี้ช่วยให้คุณเรียนรู้เกี่ยวกับโปรโตคอล SNMP และวิธีที่คุณสามารถเปิดใช้งานและกำหนดค่า SNMP service ใน Windows 10
อ่านต่อ: Free Network and Internet Traffic Monitor Tools for Windows 11/10
